// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(je|jé)").unwrap();
let string = "Aserejé, ja deje tejebe tude jebere
Sebiunouba majabi an de bugui an de buididipí
Aserejé, ja deje tejebe tude jebere
Sebiunouba majabi an de bugui an de buididipí
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}