const regex = /(je|jé)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(je|jé)', 'g')
const str = `Aserejé, ja deje tejebe tude jebere
Sebiunouba majabi an de bugui an de buididipí
Aserejé, ja deje tejebe tude jebere
Sebiunouba majabi an de bugui an de buididipí
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}