import re
regex = re.compile(r"(je|jé)")
test_str = ("Aserejé, ja deje tejebe tude jebere\n"
"Sebiunouba majabi an de bugui an de buididipí\n"
"Aserejé, ja deje tejebe tude jebere\n"
"Sebiunouba majabi an de bugui an de buididipí\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")