using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"}\n(\s*){";
string substitution = @"}\n\1},\n\1{";
string input = @" [
{
""ID"" : 230110850,
""geometry"" : {
""type"" : ""Point"",
""s1"" : [ 22.226, 60.4 ]
},
""properties"" : {
""timestamp"" : 54,
}
{
""ID"" : 265527480,
""type"" : ""Feature"",
""geometry"" : {
""type"" : ""Point"",
""s1"" : [ 22.2, 60.432 ]
},
""properties"" : {
""timestamp"" : 54,
}
]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}