# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"}\n(\s*){"
test_str = (" [\n"
" {\n"
" \"ID\" : 230110850,\n"
" \"geometry\" : {\n"
" \"type\" : \"Point\",\n"
" \"s1\" : [ 22.226, 60.4 ]\n"
" },\n"
" \"properties\" : {\n"
" \"timestamp\" : 54,\n"
" }\n"
" {\n"
" \"ID\" : 265527480,\n"
" \"type\" : \"Feature\",\n"
" \"geometry\" : {\n"
" \"type\" : \"Point\",\n"
" \"s1\" : [ 22.2, 60.432 ]\n"
" },\n"
" \"properties\" : {\n"
" \"timestamp\" : 54,\n"
" }\n"
"]")
subst = "}\\n\\1},\\n\\1{"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.