const regex = new RegExp('}\\n(\\s*){', 'gm')
const str = ` [
{
"ID" : 230110850,
"geometry" : {
"type" : "Point",
"s1" : [ 22.226, 60.4 ]
},
"properties" : {
"timestamp" : 54,
}
{
"ID" : 265527480,
"type" : "Feature",
"geometry" : {
"type" : "Point",
"s1" : [ 22.2, 60.432 ]
},
"properties" : {
"timestamp" : 54,
}
]`;
const subst = `}\n\1},\n\1{`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);