use strict;
my $str = ' [
{
"ID" : 230110850,
"geometry" : {
"type" : "Point",
"s1" : [ 22.226, 60.4 ]
},
"properties" : {
"timestamp" : 54,
}
{
"ID" : 265527480,
"type" : "Feature",
"geometry" : {
"type" : "Point",
"s1" : [ 22.2, 60.432 ]
},
"properties" : {
"timestamp" : 54,
}
]';
my $regex = qr/}\n(\s*){/mp;
my $subst = '}\\n\\1},\\n\\1{';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";