re = /}\n(\s*){/m
str = ' [
{
"ID" : 230110850,
"geometry" : {
"type" : "Point",
"s1" : [ 22.226, 60.4 ]
},
"properties" : {
"timestamp" : 54,
}
{
"ID" : 265527480,
"type" : "Feature",
"geometry" : {
"type" : "Point",
"s1" : [ 22.2, 60.432 ]
},
"properties" : {
"timestamp" : 54,
}
]'
subst = '}\\n\\1},\\n\\1{'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result