package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)}\n(\s*){`)
var str = ` [
{
"ID" : 230110850,
"geometry" : {
"type" : "Point",
"s1" : [ 22.226, 60.4 ]
},
"properties" : {
"timestamp" : 54,
}
{
"ID" : 265527480,
"type" : "Feature",
"geometry" : {
"type" : "Point",
"s1" : [ 22.2, 60.432 ]
},
"properties" : {
"timestamp" : 54,
}
]`
var substitution = "}\n\1},\n\1{"
fmt.Println(re.ReplaceAllString(str, substitution))
}