#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)\=\"([a-zA-Z0-9 ,.\/&%?=]+)\""
Local $sString = "<match id="18" srs="ICC Womens World Cup Qualifier, 2010" mchDesc="BANW vs PMGW" mnum="4th Match">" & @CRLF & _
"<match id="18" type="ODI" srs="ICC Womens World Cup Qualifier, 2017" mchDesc="BANW vs PMGW" mnum="4th Match, Group B" vcity="Colombo" vcountry="Sri Lanka" grnd="Colombo Cricket Club Ground" inngCnt="0" datapath="google.com/j2me/1.0/match/2017/index.php?=potato&?watermelon=true"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")