# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+)\=\"([a-zA-Z0-9 ,.\/&%?=]+)\""
test_str = ("<match id=\"18\" srs=\"ICC Womens World Cup Qualifier, 2010\" mchDesc=\"BANW vs PMGW\" mnum=\"4th Match\">\n"
"<match id=\"18\" type=\"ODI\" srs=\"ICC Womens World Cup Qualifier, 2017\" mchDesc=\"BANW vs PMGW\" mnum=\"4th Match, Group B\" vcity=\"Colombo\" vcountry=\"Sri Lanka\" grnd=\"Colombo Cricket Club Ground\" inngCnt=\"0\" datapath=\"google.com/j2me/1.0/match/2017/index.php?=potato&?watermelon=true\"\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.