use strict;
my $str = '<match id="18" srs="ICC Womens World Cup Qualifier, 2010" mchDesc="BANW vs PMGW" mnum="4th Match">
<match id="18" type="ODI" srs="ICC Womens World Cup Qualifier, 2017" mchDesc="BANW vs PMGW" mnum="4th Match, Group B" vcity="Colombo" vcountry="Sri Lanka" grnd="Colombo Cricket Club Ground" inngCnt="0" datapath="google.com/j2me/1.0/match/2017/index.php?=potato&?watermelon=true"
';
my $regex = qr/(\w+)\=\"([a-zA-Z0-9 ,.\/&%?=]+)\"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}