import Foundation
let pattern = #"(\w+)\=\"([a-zA-Z0-9 ,.\/&%?=]+)\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<match id="18" srs="ICC Womens World Cup Qualifier, 2010" mchDesc="BANW vs PMGW" mnum="4th Match">
<match id="18" type="ODI" srs="ICC Womens World Cup Qualifier, 2017" mchDesc="BANW vs PMGW" mnum="4th Match, Group B" vcity="Colombo" vcountry="Sri Lanka" grnd="Colombo Cricket Club Ground" inngCnt="0" datapath="google.com/j2me/1.0/match/2017/index.php?=potato&?watermelon=true"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)