// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\w+)\=\"([a-zA-Z0-9 ,.\/&%?=]+)\""#).unwrap();
let string = "<match id=\"18\" srs=\"ICC Womens World Cup Qualifier, 2010\" mchDesc=\"BANW vs PMGW\" mnum=\"4th Match\">
<match id=\"18\" type=\"ODI\" srs=\"ICC Womens World Cup Qualifier, 2017\" mchDesc=\"BANW vs PMGW\" mnum=\"4th Match, Group B\" vcity=\"Colombo\" vcountry=\"Sri Lanka\" grnd=\"Colombo Cricket Club Ground\" inngCnt=\"0\" datapath=\"google.com/j2me/1.0/match/2017/index.php?=potato&?watermelon=true\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}