using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1\.1\.1\.[12]\d{2}";
string input = @"Как в куче IP адресов с помощью регулярных выражений найти IP адреса вида 1.1.1.X, у которых X это 100-200?
тоесть 1.1.1.100, 1.1.1.101, 1.1.1.102 итд
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}