// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)1\.1\.1\.[12]\d{2}").unwrap();
let string = "Как в куче IP адресов с помощью регулярных выражений найти IP адреса вида 1.1.1.X, у которых X это 100-200?
тоесть 1.1.1.100, 1.1.1.101, 1.1.1.102 итд
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}