use strict;
my $str = 'Как в куче IP адресов с помощью регулярных выражений найти IP адреса вида 1.1.1.X, у которых X это 100-200?
тоесть 1.1.1.100, 1.1.1.101, 1.1.1.102 итд
';
my $regex = qr/1\.1\.1\.[12]\d{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}