re = /1\.1\.1\.[12]\d{2}/m
str = 'Как в куче IP адресов с помощью регулярных выражений найти IP адреса вида 1.1.1.X, у которых X это 100-200?
тоесть 1.1.1.100, 1.1.1.101, 1.1.1.102 итд
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end