import re
regex = re.compile(r"1\.1\.1\.[12]\d{2}", flags=re.MULTILINE)
test_str = ("Как в куче IP адресов с помощью регулярных выражений найти IP адреса вида 1.1.1.X, у которых X это 100-200?\n"
"тоесть 1.1.1.100, 1.1.1.101, 1.1.1.102 итд\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")