# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<script[^>]+?src=(['"]?)([^\s>]+)\1[^>]*>(<\\/script>)?/\2/g;t' <<< "<script class=\"anyClass\" src=\"anyFile.js\" id=\"anyID\">
<script class=\"anyClass\" src=\"anyFile.js\">
<script src=\"anyFile.js\" id=\"anyID\">
<script src=\"anyFile.js\">
<script class='anyClass' src='anyFile.js' id='anyID'>
<script class='anyClass' src='anyFile.js'
<script src='anyFile.js' id='anyID'>
<script src='anyFile.js'>
<script class=anyClass src=anyFile.js id=anyID>
<script class=anyClass src=anyFile.js>
<script src=anyFile.js id=anyID>
<script src=anyFile.js >"