use strict;
my $str = '<script class="anyClass" src="anyFile.js" id="anyID">
<script class="anyClass" src="anyFile.js">
<script src="anyFile.js" id="anyID">
<script src="anyFile.js">
<script class=\'anyClass\' src=\'anyFile.js\' id=\'anyID\'>
<script class=\'anyClass\' src=\'anyFile.js\'
<script src=\'anyFile.js\' id=\'anyID\'>
<script src=\'anyFile.js\'>
<script class=anyClass src=anyFile.js id=anyID>
<script class=anyClass src=anyFile.js>
<script src=anyFile.js id=anyID>
<script src=anyFile.js >';
my $regex = qr/<script[^>]+?src=(['"]?)([^\s>]+)\1[^>]*>(<\/script>)?/p;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";