re = /<script[^>]+?src=(['"]?)([^\s>]+)\1[^>]*>(<\/script>)?/
str = '<script class="anyClass" src="anyFile.js" id="anyID">
<script class="anyClass" src="anyFile.js">
<script src="anyFile.js" id="anyID">
<script src="anyFile.js">
<script class=\'anyClass\' src=\'anyFile.js\' id=\'anyID\'>
<script class=\'anyClass\' src=\'anyFile.js\'
<script src=\'anyFile.js\' id=\'anyID\'>
<script src=\'anyFile.js\'>
<script class=anyClass src=anyFile.js id=anyID>
<script class=anyClass src=anyFile.js>
<script src=anyFile.js id=anyID>
<script src=anyFile.js >'
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result