const regex = /<script[^>]+?src=(['"]?)([^\s>]+)\1[^>]*>(<\/script>)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script[^>]+?src=([\'"]?)([^\\s>]+)\\1[^>]*>(<\\\/script>)?', 'g')
const str = `<script class="anyClass" src="anyFile.js" id="anyID">
<script class="anyClass" src="anyFile.js">
<script src="anyFile.js" id="anyID">
<script src="anyFile.js">
<script class='anyClass' src='anyFile.js' id='anyID'>
<script class='anyClass' src='anyFile.js'
<script src='anyFile.js' id='anyID'>
<script src='anyFile.js'>
<script class=anyClass src=anyFile.js id=anyID>
<script class=anyClass src=anyFile.js>
<script src=anyFile.js id=anyID>
<script src=anyFile.js >`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);