import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<script[^>]+?src=(['\"]?)([^\\s>]+)\\1[^>]*>(<\\/script>)?";
final String string = "<script class=\"anyClass\" src=\"anyFile.js\" id=\"anyID\">\n"
+ "<script class=\"anyClass\" src=\"anyFile.js\">\n"
+ "<script src=\"anyFile.js\" id=\"anyID\">\n"
+ "<script src=\"anyFile.js\">\n\n\n"
+ "<script class='anyClass' src='anyFile.js' id='anyID'>\n"
+ "<script class='anyClass' src='anyFile.js'\n"
+ "<script src='anyFile.js' id='anyID'>\n"
+ "<script src='anyFile.js'>\n\n"
+ "<script class=anyClass src=anyFile.js id=anyID>\n"
+ "<script class=anyClass src=anyFile.js>\n"
+ "<script src=anyFile.js id=anyID>\n"
+ "<script src=anyFile.js >";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}