#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<script[^>]+?src=(['"]?)([^\s>]+)\1[^>]*>(<\/script>)?"
Local $sString = "<script class="anyClass" src="anyFile.js" id="anyID">" & @CRLF & _
"<script class="anyClass" src="anyFile.js">" & @CRLF & _
"<script src="anyFile.js" id="anyID">" & @CRLF & _
"<script src="anyFile.js">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<script class='anyClass' src='anyFile.js' id='anyID'>" & @CRLF & _
"<script class='anyClass' src='anyFile.js'" & @CRLF & _
"<script src='anyFile.js' id='anyID'>" & @CRLF & _
"<script src='anyFile.js'>" & @CRLF & _
"" & @CRLF & _
"<script class=anyClass src=anyFile.js id=anyID>" & @CRLF & _
"<script class=anyClass src=anyFile.js>" & @CRLF & _
"<script src=anyFile.js id=anyID>" & @CRLF & _
"<script src=anyFile.js >"
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)