using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script[^>]+?src=(['""]?)([^\s>]+)\1[^>]*>(<\/script>)?";
string substitution = @"\2";
string input = @"<script class=""anyClass"" src=""anyFile.js"" id=""anyID"">
<script class=""anyClass"" src=""anyFile.js"">
<script src=""anyFile.js"" id=""anyID"">
<script src=""anyFile.js"">
<script class='anyClass' src='anyFile.js' id='anyID'>
<script class='anyClass' src='anyFile.js'
<script src='anyFile.js' id='anyID'>
<script src='anyFile.js'>
<script class=anyClass src=anyFile.js id=anyID>
<script class=anyClass src=anyFile.js>
<script src=anyFile.js id=anyID>
<script src=anyFile.js >";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}