using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[2-9]\d|[1-9]\d\d|[1-9],\d{3})(?:,\d{3})+$";
string input = @"123,456,789,012,345
12,345
19,000
20,000
21,000
023,555
21,939,323
1,232,323
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}