const regex = /^(?:[2-9]\d|[1-9]\d\d|[1-9],\d{3})(?:,\d{3})+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[2-9]\\d|[1-9]\\d\\d|[1-9],\\d{3})(?:,\\d{3})+$', 'gm')
const str = `123,456,789,012,345
12,345
19,000
20,000
21,000
023,555
21,939,323
1,232,323
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}