// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[2-9]\d|[1-9]\d\d|[1-9],\d{3})(?:,\d{3})+$").unwrap();
let string = "123,456,789,012,345
12,345
19,000
20,000
21,000
023,555
21,939,323
1,232,323
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}