$re = '/^(?:[2-9]\d|[1-9]\d\d|[1-9],\d{3})(?:,\d{3})+$/m';
$str = '123,456,789,012,345
12,345
19,000
20,000
21,000
023,555
21,939,323
1,232,323
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);