re = /^(?:[2-9]\d|[1-9]\d\d|[1-9],\d{3})(?:,\d{3})+$/m
str = '123,456,789,012,345
12,345
19,000
20,000
21,000
023,555
21,939,323
1,232,323
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end