import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[2-9]\\d|[1-9]\\d\\d|[1-9],\\d{3})(?:,\\d{3})+$";
final String string = "123,456,789,012,345\n"
+ "12,345\n"
+ "19,000\n"
+ "20,000\n"
+ "21,000\n"
+ "023,555\n"
+ "21,939,323\n"
+ "1,232,323\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}