#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)node_modules(?!\/(jquery|core-js)\/)(\/[^\/\n]+)+\.js"
Local $sString = "node_modules/autonumeric" & @CRLF & _
"node_modules/core-js" & @CRLF & _
"node_modules/jquery" & @CRLF & _
"node_modules/jquery-ui" & @CRLF & _
"node_modules/jquery.watch" & @CRLF & _
"node_modules/marked" & @CRLF & _
"" & @CRLF & _
"node_modules/core-js" & @CRLF & _
"node_modules/jquery" & @CRLF & _
"" & @CRLF & _
"The second vendor bundle should contain all the other bundles in node_modules, except for jquery and core-js (That means the regex must match jquery-ui)." & @CRLF & _
"" & @CRLF & _
"node_modules/autonumeric/abc.js" & @CRLF & _
"node_modules/jquery-ui/abc.js" & @CRLF & _
"node_modules/jquery.watch/abc.js" & @CRLF & _
"node_modules/marked/abc.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")