import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "node_modules(?!\\/(jquery|core-js)\\/)(\\/[^\\/\\n]+)+\\.js";
final String string = "node_modules/autonumeric\n"
+ "node_modules/core-js\n"
+ "node_modules/jquery\n"
+ "node_modules/jquery-ui\n"
+ "node_modules/jquery.watch\n"
+ "node_modules/marked\n\n"
+ "node_modules/core-js\n"
+ "node_modules/jquery\n\n"
+ "The second vendor bundle should contain all the other bundles in node_modules, except for jquery and core-js (That means the regex must match jquery-ui).\n\n"
+ "node_modules/autonumeric/abc.js\n"
+ "node_modules/jquery-ui/abc.js\n"
+ "node_modules/jquery.watch/abc.js\n"
+ "node_modules/marked/abc.js";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}