const regex = /node_modules(?!\/(jquery|core-js)\/)(\/[^\/\n]+)+\.js/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('node_modules(?!\\\/(jquery|core-js)\\\/)(\\\/[^\\\/\\n]+)+\\.js', 'gm')
const str = `node_modules/autonumeric
node_modules/core-js
node_modules/jquery
node_modules/jquery-ui
node_modules/jquery.watch
node_modules/marked
node_modules/core-js
node_modules/jquery
The second vendor bundle should contain all the other bundles in node_modules, except for jquery and core-js (That means the regex must match jquery-ui).
node_modules/autonumeric/abc.js
node_modules/jquery-ui/abc.js
node_modules/jquery.watch/abc.js
node_modules/marked/abc.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}