re = /node_modules(?!\/(jquery|core-js)\/)(\/[^\/\n]+)+\.js/m
str = 'node_modules/autonumeric
node_modules/core-js
node_modules/jquery
node_modules/jquery-ui
node_modules/jquery.watch
node_modules/marked
node_modules/core-js
node_modules/jquery
The second vendor bundle should contain all the other bundles in node_modules, except for jquery and core-js (That means the regex must match jquery-ui).
node_modules/autonumeric/abc.js
node_modules/jquery-ui/abc.js
node_modules/jquery.watch/abc.js
node_modules/marked/abc.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end