# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"node_modules(?!\/(jquery|core-js)\/)(\/[^\/\n]+)+\.js"
test_str = ("node_modules/autonumeric\n"
"node_modules/core-js\n"
"node_modules/jquery\n"
"node_modules/jquery-ui\n"
"node_modules/jquery.watch\n"
"node_modules/marked\n\n"
"node_modules/core-js\n"
"node_modules/jquery\n\n"
"The second vendor bundle should contain all the other bundles in node_modules, except for jquery and core-js (That means the regex must match jquery-ui).\n\n"
"node_modules/autonumeric/abc.js\n"
"node_modules/jquery-ui/abc.js\n"
"node_modules/jquery.watch/abc.js\n"
"node_modules/marked/abc.js")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.