import Foundation
let pattern = #"node_modules(?!\/(jquery|core-js)\/)(\/[^\/\n]+)+\.js"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
node_modules/autonumeric
node_modules/core-js
node_modules/jquery
node_modules/jquery-ui
node_modules/jquery.watch
node_modules/marked
node_modules/core-js
node_modules/jquery
The second vendor bundle should contain all the other bundles in node_modules, except for jquery and core-js (That means the regex must match jquery-ui).
node_modules/autonumeric/abc.js
node_modules/jquery-ui/abc.js
node_modules/jquery.watch/abc.js
node_modules/marked/abc.js
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)