use strict;
my $str = 'node_modules/autonumeric
node_modules/core-js
node_modules/jquery
node_modules/jquery-ui
node_modules/jquery.watch
node_modules/marked
node_modules/core-js
node_modules/jquery
The second vendor bundle should contain all the other bundles in node_modules, except for jquery and core-js (That means the regex must match jquery-ui).
node_modules/autonumeric/abc.js
node_modules/jquery-ui/abc.js
node_modules/jquery.watch/abc.js
node_modules/marked/abc.js';
my $regex = qr/node_modules(?!\/(jquery|core-js)\/)(\/[^\/\n]+)+\.js/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}