#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https://download\.pascom\.net/release-archive/client/stable/pascom Client-64\.\S.*\.dmg"
Local $sString = "{"windows": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.exe"}, "linux": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.tar.bz2"}, "macos": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.dmg"}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")