import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://download\\.pascom\\.net/release-archive/client/stable/pascom Client-64\\.\\S.*\\.dmg";
final String string = "{\"windows\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.exe\"}, \"linux\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.tar.bz2\"}, \"macos\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.dmg\"}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}