import Foundation
let pattern = #"https://download\.pascom\.net/release-archive/client/stable/pascom Client-64\.\S.*\.dmg"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"windows": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.exe"}, "linux": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.tar.bz2"}, "macos": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.dmg"}}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)