// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https://download\.pascom\.net/release-archive/client/stable/pascom Client-64\.\S.*\.dmg").unwrap();
let string = "{\"windows\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.exe\"}, \"linux\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.tar.bz2\"}, \"macos\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.dmg\"}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}