import re
regex = re.compile(r"https://download\.pascom\.net/release-archive/client/stable/pascom Client-64\.\S.*\.dmg", flags=re.MULTILINE)
test_str = "{\"windows\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.exe\"}, \"linux\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.tar.bz2\"}, \"macos\": {\"checksum-url\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.md5\", \"version\": \"64.R1156\", \"checksum-url-sha256\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.sha256\", \"url\": \"https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.dmg\"}}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")