package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https://download\.pascom\.net/release-archive/client/stable/pascom Client-64\.\S.*\.dmg`)
var str = `{"windows": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.exe"}, "linux": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.tar.bz2"}, "macos": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.dmg"}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}