use strict;
my $str = '{"windows": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom-client-setup-64.R1156_844c4e1.exe"}, "linux": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom_Client-64.R1156_844c4e1.tar.bz2"}, "macos": {"checksum-url": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.md5", "version": "64.R1156", "checksum-url-sha256": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.sha256", "url": "https://download.pascom.net/release-archive/client/stable/pascom Client-64.R1156_844c4e1.dmg"}}';
my $regex = qr/https://download\.pascom\.net/release-archive/client/stable/pascom Client-64\.\S.*\.dmg/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}