# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^\[]+//gm;t' <<< "Order[NN(STTS)]
523:10[CARD(STTS)]
Euro12[NN(STTS)]"