re = /^[^\[]+/m
str = 'Order[NN(STTS)]
523:10[CARD(STTS)]
Euro12[NN(STTS)]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result