$re = '/^[^\[]+/m';
$str = 'Order[NN(STTS)]
523:10[CARD(STTS)]
Euro12[NN(STTS)]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;