use strict;
my $str = 'Order[NN(STTS)]
523:10[CARD(STTS)]
Euro12[NN(STTS)]';
my $regex = qr/^[^\[]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";